After I open a file in Rhino 5, I get this window (Encounter improper argument), my command prompt disappears and so my layer window if opened. Sometimes after fixing my command prompt, it will happen again with the same results.

bug.jpg

Tags: Bug

Views: 522

Replies to This Discussion

Hello- are you using any plug-ins that are not installed by default with plain Rhino 5? Does this happen with any file?

-Pascal

pascal@mcneel.com

I have Tsplines installed but not using the plugin when the bug appears. Sometimes I am using tsplines, sometimes not. For example I was working on a file right now and decided to open another instance of Rhino 5. As soon as I clicked the rhino 5 icon on the windows taskbar the bug showed up.

Hi all,

I am having the same problem but with the Object Properties Panel.

Steps to recreate the bug:

1. Start Rhino 5 64 bit (Windows 7 64 SP1)

2. Click on the Rhino button in the Taskbar

3. The aforementioned window pops up and the Object Properties Panel is gone.

4. Bring it up again

5. Click on the Rhino button in the Taskbar

6. The Object Properties Panel is NOT gone and it stays there for the whole session

If I close Rhino and restart it, it's the same all over again. There are no plugins installed.

It's not much of a problem, but it would be nice to have it fixed at some point

Thank you in advance,

Tassos Ringas

Hi Tassos, Kin- does this happen if you start  Rhino in Safe mode? (Windows (7) Start menu > type Rhinoceros in the search box and look for 'Rhinoceros 5(64 bit) in Safe Mode' .

thanks, 

-Pascal

pascal@mcneel.com

Bump

Hi Pascal,

In safe mode, when I load all plugins, I am still getting the bug.

If I don't load any of them, it goes away, but I have no toolbars, options, nothing.

At the moment, it's a little glitch, not much of a problem.

Tassos Ringas

Hi Tassos- if you have the patience, can you disable some plug-ins and see if you can determine which is causing trouble- I would start with any that are not default Rhino plug-ins- disable these, if any, and see if things work better; if not, then try disabling the toolbar plug-in- (Rhino Toolbars and Menus) and possibly Renderer Development Kit. Disabling plug-ins is done in Options > Plug-ins page. If you can send me a screen shot of the plug-ins you have loaded normally (You can filter the view in the Plug-ins page) , I can maybe suggest ones to try and disable.

thanks,

-Pascal

pascal@mcneel.com

Hi Pascal,

I think I nailed it!

It is caused by the Mesh Repair Panel, if this is open it causes the bug, if not the bug goes away.

It doesn't seem to have anything to do with plugins, it doesn't matter if the Mesh Repair plugin is loaded or not, just the respective panel.

Check it and let me know.

Tassos Ringas

Hi Tassos- thanks... unfortunately, so far I am not seeing this. Very frustrating... I'd love to track this down. I'll keep testing, thanks for all your help.

-Pascal

pascal@mcneel.com

One little thing I forgot to mention...

I am using a dual screen, all toolbars are undocked, I have no titlebar on them viewport window and I am using a custom rui file along with the default one.

Maybe it's a combination of something, but my Rhino is heavily customised, back from the gelfling days, if you know what I mean :-)

Tassos Ringas

I am also using a dual screen with all the toolbars undocked on the second monitor. I got to say that I disabled the Mesh repair plugin (as Tassos) and so far my session today has been bug free.

OK, thanks to you both, I'll set up something more like what you have.

-Pascal

pascal@mcneel.com

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service