I've got a file with a few dozen different blocks in it. When I double-click a block to edit it, Rhino hangs (endless spinning thing). I've let it spin for up to 5 minutes before closing Rhino. (forcing it to quit). Selecting the block and typing "BlockEdit" has same effect. This just started happening today. Been working on the file for about a week, making and editing blocks with no trouble.

Things I've tried: praying (not really), purging, selbadobjects (nothing), exporting the block to a new file and editing it there (that works, but I'd really rather not).

The file is 130'ish Mb. I'll upload it if somebody wants to look at it.

I'm running Rhino5 64 bit. I've tried shutting down computer and restarting and opening Rhino again, then BlockEdit (or double-click on block), same hang.

Views: 83

Replies to This Discussion

Might have isolated the culprit. A couple days ago I imported some stuff from an oooooold Rhino file and that's about when the BlockEdit stopped working. If I select everything in my current file (except the suspect imported geometry) and export to new file... BlockEdit works again! If I export just the suspect geometry to a new file and open that file... BlockEdit also works in that file. :/

Taking a closer look at the exported file of suspect stuff it was a mix of meshes and polysurfs and extrusion objects and *no* blocks. I got rid of the meshes and saved the file, then imported it to the main file... BlockEdit still works in the main file.

Hi Henry- please upload the misbehaving file to 

http://www.rhino3d.com/upload

Add a line or two to remind us of the problem.

Thanks.

-Pascal

pascal@mcneel.com

The upload thing's not working for me. Here's a link to the file via dropbox: file

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service