Hi,

a while back, I had installed a Rhino SDK on my machine. Ever since, when Rhino starts, it displays the message

"Rhino debugging error dialogs enabled. Use the "TestErrorCheck" command to adjust settings

and from then on, many commands cause verbose error/warning messages to appear. They are benign but really destroy the workflow because one constantly has to click away these messages.

Uninstalling the SDK did not stop this behavior. Neither did the aforementioned "TestErrorCheck" command, because these error messages are re-enabled every time I restart Rhino.

This is really driving me crazy -- it would be great to know if there is some registry flag or Rhino option that I can toggle to get rid of these messages.

Thanks,
Wenzel

Views: 147

Replies to This Discussion

Someone on the dinosaur plug-ins newsgroup seems to have had the same problem...  Below is his solution, maybe it will help.  ----H

"Kept fooling around trying to find a solution: I changed "TestErrorCheck
E=off" to "TestErrorCheck E=off _EnterEnd". That worked OK to undo the
default setting of E=on. It probably would have worked OK with just EnterEnd
in my English language setup, but those using Rhino in a different language
will, of course, need the underscore before each English command word (not
sure about the E=off)."

More on this:

"TestErrorCheck looks to see if the C++ SDK is installed by looking in the
registry for the existence of
HKEY_CURRENT_USER\Software\McNeel\Rhinoceros\SDK
and turns itself on if that key exists. You could delete the key (or rename
it if you are cautious) so Rhino doesn't think the C++ SDK is installed and
therefore not turning TestErrorCheck on."

----H

Hello Wenzel,

There is a bug in the Rhino SDK uninstall. The Rhino SDK uninstall is failing to clean up the Windows registry. If you are comfortable using the Windows "regedit" tool, then you may use it to remove the registry path "HKEY_CURRENT_USER\\Software\\McNeel\\Rhinoceros\\SDK" and Rhino will no longer assume you have the SDK installed.

I've created a bug report so we can get the SDK uninstall to clean up the registry. The bug number is 121859. If you contact technical support about this issue, please include this bug number.

Thanks for using Rhino!

-- Dale Lear

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service