Please stop the Splash Screen from taking over computer.

Is anyone else noticing how the Rhino 5 splash screen won't let any other windows exist in the foreground?

The interactivity of the Rhino 5 splash screen is fantastic. It's great having all the recent document and new file options available before Rhino even finishes loading.  However, it doesn't let me open Rhino in the background. Maybe it has to do with the fading effects, but it steals focus multiple times throughout it's existence. It may only be for 15 seconds for a new document on a quick system, but holding your computer hostage for any time is bothersome. I think most people would prefer to let their large CAD files open in the background while finishing an email than sit and watch it load.

Additionally, if your mouse happens to be hovering over the splash screen, it will steal focus from Rhino's own messages. For example if there is a warning message like, "Missing Block Definition File...Do you want to browse for the file?" The splash screen won't reveal the important prompt for quite some time if the quantity of block definitions are high.

A nagging splash screen just doesn't fit Rhino's image. Rhino needs no artificial help to get noticed, especially among those who use and love it. Its countless virtues as a design program speak for themselves; Alone, they compel one's attention.

Please make the splash screen behave.

Tags: splash

Views: 757

Replies to This Discussion

Hi Gabe,

Thanks for the feedback. This is on the list to improve shortly. Currently we're trying to figure out why the splash screen causes Rhino to sometimes take 15 minutes to start on some computers.

15 minutes! I guess I have little to complain about. I'm glad the splash screen is being worked on though. 

I just discovered this forum and this is the first time I have posted here. Is this the preferred place to interact with Rhino 5 developers for problems and suggestions? It seems like it is; However, the forum doesn't seem to be as active as I had imagined for such an important development (preconceptions based on the grasshopper forum). And, in my prior search for posts regarding the splash screen, nothing came up. I would imagine these bugs are being reported somewhere, if not here.

Any idea how long this "improve shortly" will take? This always-on-top-behaviour is absolutely annoying even if it just takes 15 seconds and not 15 minutes.

Hi Drk,

I too have wished for the Rhino start up to stop taking focus multiple times but you can get rid of the splash screen by clicking the cross in the top right hand corner while rhino continues to start up. It doesn't help with the fact that if you are trying to do meaningful things like type emails you find them going in the command line but it does mean you can at least read emails. 

There is another thing I do because of needing to start and stop Rhino so often for tech support. It's pretty drastic and I don't recommend it unless you're really in a bind.

You can make a DesktopShort cut that starts Rhino without the Splash screen.

The first step is to copy one of your Desktop shortcuts. Modify the Target line and add the /nosplash argument. for 64-bit V5, it would look like this:

"C:\Program Files\Rhinoceros 5 (64-bit)\System\Rhino.exe" /nosplash

The second is to edit your Open icon in the Standard Toolbar to run About instead of Open. Then you'll have a button to get to the handy Splash Screen when you want it.

Attachments:

Thanks John.

Nice time.. but of course now I question myself if I actually clicked it :)

Great help as long as you don't start Rhino by double-clicking a .3dm file which I prefer to do in more than 90%. Where to put /nosplash then?

And, it's not the splash screen that's bad, it's this one single bit set (HWND_TOPMOST or for .Net "TopMost=true") for the window preferences.

Any changes to this behaviour or a commandline option like /notopmost appreciated. Thanks!

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service