Hello,

When I try to render using Rhino render, my system just hangs. Sometimes it says "creating meshes", sometimes not, but the hourglass remains until I hit Enter, at which point I get a "Rhino is not responding". Sometimes a get a white smear where the object was. It had been working until fairly recently, so I reset to default, to no avail. I'm using Windows 6 (sorry) with a Radeon x1300/x1500 card. Thanks.

Views: 305

Replies to This Discussion

Hi John- is this the case with any file or only some? If only some, try SelbadObjects and see if anything rings up- these can be very hard on the mesher.  Feel free to post or send me a file for a look.

-Pascal

pascal@mcneel.com

Hi Pascal, this happens even with something as simple as a cylinder. What file would be helpful to send? Thanks.

Hi John- sure, please send a file- maybe the mesh settings are all out of whack in the template you are starting from. If it is hanging in actually generating the meshes for simple objects then that is where I'd start.

-Pascal

pascal@mcneel.com

Er,  Pascal, I think I need a little guidance as to what file you're interested in. I'm not very familiar with Rhino's innards.

Thanks,

John

Hi John- just make a simple file in Rhino that exhibits the problem that you are describing and than send me or post that file- I am not very optimistic that this will be enough to track down the problem but I'd like to have a look.

thanks, 

-Pascal

pascal@mcneel.com

Hi Pascal. I completely uninstalled and reinstalled Rhino and am still having the same problem. Attached is a screenshot of my attempt to render a sphere. I also have tsplines loaded, so perhaps this is an issue?

Thanks.

John

Attachments:

Hi John- a picture dopes not really help- please send me the Rhino file.

thanks, 

-Pascal

pascal@mcneel.com

H Pascal,

Attachments:

Hi John- thanks- the file looks fine here, as expected, I guess- it meshes just fine.... So, lets try blocking plug-ins- Open Options > PLug-ins page, and set the view to show 'Plug-ins that do not ship with Rhino' and uncheck the Enabled check box for all that you find there, then restart Rhino- does that work any better?

-Pascal

pascal@mcneel.com

Hi Pascal, I just tried as you suggested -I had 4 such plugins - but nothing has changed. My last reply got clipped apparently. I mentioned that when I open a new file, I always get "root element is missing". I do see all my toolbars however. And, when I look in Task Manager, it says I'm running Rhino 4.

Thanks,

John

My guess of the moment is that meshing is not the real problem, it is video- I would make sure the video card drivers are up to date, and you might even try changing the setting in Options > View OPenGL for 'Use hardware accelerated modes'. 

You can check the meshing part by running ExtractRenderMesh- does that get you anything or does it hang?

-Pascal

pascal@mcneel.com

Hi Pascal, the 'reply' function seems to be messed up, so I am using a prior post. There is a new wrinkle: I was able to get a mesh using ExtractRenderMesh and I was using 'hardware accelerated modes' but when I unchecked it, I was able to render! OTOH, I can't use antialiasing, so the results are jagged. Could the fact that the system seems to think I'm using Rhino 4 be a problem? In Rhino 4, I have no problem rendering.

Thanks,

John

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service