rhino 5 _ Big Problem with units, tolerances, moving objects

Hi there,

We are using Rhino 5.0 on a windows 7 machine.

We had rhino 4 before and it worked fine.

now with rhino 5 i noticed some problems.

usually when i draw a poly-line i klick for first point and then type into the command line the distance for the second point, lets say a " 2 " for two centimeters. when i wanted the second point to be 2.5 cm away i typed in "2.5".

but this doesnt work anymore. I only can use fractions which would be 2-1/2 althought i have set decimals in the settings. I furthermore tried different keyboards (US instead of German) seems not to work. Same problem with copying object to a set distance...

Then I noticed that all of a sudden I cant set the tolerances. Suddenly in centimeters there is a tolerance of 0.0

When i try to change that (which also is only possible as a fraction) to 0.01 it changes back to 0.0 automatically when i click ok and re-open the settings.

somtimes this occurs and sometimes not.

so if anyone could give me any advice for the decimal / fraction issue and the tolerance issue that would be really great !

thanks in advance

Tags: decimal, fraction, tolerance

Views: 2844

Attachments:

Replies to This Discussion

Hi Tom- if you start a brand mew model using your default template file, does any of this work?  If you start a new model using New  and then  the 'No Template' button in the New file dialog, does this behave any differently?

 

thanks,

-Pascal

pascal@mcneel.com

hi pascal,

i will try that as you have described ...

thanks so far ! i ll let you know which results i get .

thank you very much !

do you have any idea why i just cant switch to decimals instead of fractions ?

cheers

gunther

Hi Gunther- I do not have an idea about the fraction/decimal entry- my only suggestions, while I ask someone who is smarter than me, are

1. Restart the machine... in case you have not.

2. Start Rhino in Safe Mode ( there is a Rhino in Safe Mode icon in the Rhino program group in the Start menu) - does that work any differently?

3. Check for some utility that you may be running, even if it is not related to Rhino- I don't know what it might be- something that 'helps' the Windows UI...?

-Pascal

Pascal@mcneel.com

hi there ,

ok, I seem to have found out what the problem could be.

the problem occured when using the 32 bit version on a 64 bit engine (as we have vray as well which only works on 32 bit. so if i start drawing in rhino 5 32 bit everything is fine, the tolerence setting and the decimals. in safe mode and in normal mode. but as soon as i import a dxf or even a rhino object both problems occur in both modes (in safe mode I have to allow some plug ins in order to import sth.) working with the 64 bit version there seems to be no problem.

so I guess i might work with the 64 bit and maybe at the end copy the object to the 32 bit version in order to render it with vray undtil we have a newer vray version :)

big thank you for your help !!!

Hello- this is still very odd, even if you have a partial workaround - are you running Rhino in German? I'd love to be able to reproduce this, and fix it...

"(in safe mode I have to allow some plug ins in order to import sth.)"

Can you please tell me what all the plug-ins are that try to load when you import?

thanks, 

-Pascal

pascal@mcneel.com

Hi Pascal,

I am having the same exact same problem!

I can not see that you found any solution to the problem. Anyway, I am running the latest release of Rhino 5 on a Mac Pro via Boot Camp and Windows Vista 32-bit. I did not have the problem in Rhino 4. Starting Rhino 5 in safe mode seems to solve the problem until I open an old document where tolerances are set to 0.0 and can not be changed. After that, I get the problem in all new documents I create in safe mode whether I use a template or not. I am suspecting that RhinoWorks has caused the problem. I installed it with the first installation of Rhino 5. But after learning that it might not be 100% compatible with Rhino 5 I uninstalled it per their instructions. I also reinstalled Rhino 5. Can some preference file be laying around somewhere?

Please help before I go insane! When the tolerances are set to 0 nothing works (booleans, splits, fillets...)

Best regards

Lars

Attachments:

Hi Lars- 

"Starting Rhino 5 in safe mode seems to solve the problem until I open an old document where tolerances are set to 0.0 and can not be changed. After that, I get the problem in all new documents I create in safe mode whether I use a template or not."

This should be... impossible. The No Template for a new file uses hard coded .001 mm tolerance. There should be no other possibility. Since it is happening,  we (Rhino) either have a pretty serious problem to track down, or, there is something happening with a plug-in even is Safe mode... or something. Bootcamp should not come into play here but one never knows.  Can you please try opening Rhino normally and check in PlugInManager with the view filtered for 'Plug-ins that do not ship with Rhino' Are there any plug-ins listed?

thanks

-Pascal

pascal@mcneel.com

 

Hi again,

Thanks for your quick reply!

I have included screen dump.

/Lars

Attachments:

This is weird!
This is what is happening:
I have started Rhino normally.
I open a document that has reset the tolerance to 0.0.
I open a new document without a template.
I draw a cube.
I go to Rhino OPTIONS to check the tolerance settings.
I click on UNITS and it says 0.001 mm which is OK. (img1)
I then click on MODEL. Tolerance is now 0.0 (img2)
I then click LAYOUT and is says 0.001
When I click UNITS again tolerance is set to 0.0!!! (img4)

Attachments:

Hi Lars- thanks- I am still mystified that you cannot change the setting. We did get some reports of tolerance set to zero, but not that these could not  be changed, and we made some changes for SR3  such that Rhino will not allow files that have tolerance set to zero to open that way but will force a default tolerance. Now, I am not sure that this will fix your problem but it might - you can try it by enabling Release candidates in the Updates page of Options:

 
To enable updates to service release candidates, set Options > Updates and Statistics > 'Update frequency' to 'Service release candidate'. Rhino will look for these, download them in the background and offer to install once that is done and you are either opening or closing Rhino.
See if that does anything useful.
-Pascal
pascal@mcneel.com

There is something odd with your unit system.  The images you posted have commas as decimal separators in the input boxes, IMO, they should be periods.  I've never seen commas in these dialogs...

----H

Hi Pascal,

if I may join in on this. I am experiencing the same problem. I've tracked down the reproducability to this. It is only happening in Rhino 5 32bit, any service pack. 64bit is fine, Rhino 4 SR9 is fine.

Start Rhino 5 32bit.

Draw a cube, enter height e.g. 3.5. Works as expected.

As soon as I open any dialog like open, save as, export, etc. something gets broken. Let's say I type "open" and immediately close the dialog without doing anything.

From that point on, Rhino ignores anything behind the period.

If I draw a cube with height "3.5" it will be "3" in height.

On STL export, all the settings behave the same way, so everything behind the period is ignored and reset to .0.

The strange thing is that the period somehow doesn't look like a period or a comma. See attached picture. The same applies to any value in Rhino options. Before I open a dialog those values have a normal period. Afterwards they have this strange period.

I have tried changing the decimal separator in regional settings without success (also with windows restarts in between). I have uninstalled an reinstalled several times, I tried every service pack, it just doesn't stop.

My windows is Windows 7 64bit german edition SP1 all updates installed.

thank you for your help!

Attachments:

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service