Did the slicing feature get nixed in Rhino 5?


With the rise of personal 3D printers, this is a feature that's needed now more than ever. One of the YouTube tutorials showed the process of taking an STL file and exporting it as SLC.


I've tried finding it as a file format through Export Selected and even Save As but it's nowhere to be found.


Keyword "SLC" turned up nothing on the newsgroup or this forum.


Am I the only one not seeing it?



Views: 2096

Replies to This Discussion

Hello- slc is available as an export format ,yes-  are you seeing other formats, just not SLC? There is a pretty long list so it's easy to miss.




I checked the Rhino Options Plugin list and both SLC Export and SLC Import are checked ON.


When I do a File OPEN or IMPORT, it provides the SLC format...


..when I load an STL, highlight it, and do a File EXPORT SELECTED, the SLC listing is not available...


Sorry, wasn't sure if the last two messages where I attached screenshots came through. My browser popped up an alert asking:
"Do you want to open or save CA11UD92.js from v5.rhino3d.com?"

I killed off the alert and the progress icon kept spinning.

I emailed this issue with picture attachments.

For those following this thread and have similar problems, I poked further and might've solved it...

I just now looked under the RHINO OPTIONS PLUG-INS list.

It shows a checkmark next to each SLC IMPORT and EXPORT but no Loaded/Enabled "YES"
indicator like some other entries have.

I highlighted each one and clicked the INSTALL button.

It initially tries to find the file in my user library folder. I
redirect it to go into the C: drive, and drill into the Rhino Plug-Ins
folder. I found the respective files.

Now finally the OPTIONS PLUG-INS list has "Yes" indicators... and
revisiting the EXPORT SELECTED dialogs indeed show SLC as being

Hi Carter- the 'Yes' indicates the plug-in is loaded, the checkmark indicates the plug-in is enabled. Most plug-ins load on demand and not at startup, including Import/Export plug-ins so not having a 'Yes' should not in itself stop the file format from showing in the list. If there is no checkmark in the 'Enabled' column, that will be a problem- check the box and restart Rhino to enable that plug-in.



Hi , I also have this problem. Rhino 5 OS = Windows 7 x64

Properties says SLC Export Version is "unavailable"

But the box is checked Yes.


Hi , I also have this problem. Rhino 5 OS = Windows 7 x64

Properties says SLC Export Version is "unavailable"

But the enabled box is checked Yes. However the "Loaded " column is not checked.

Hi Jean, Carter- I see, thanks, I'll see if I can figure this out. 'Version unavailable' is not a problem in itself but I am not sure why it does not show up in your save list. Jean, you can see the path to the plug-in in the Properties page in your image - stretch the dialog out to see the entire path - if you find that file and drag and drop the rhp file onto Rhino (Options closed of course) does that help?




This has probably already been solved, but I found that the "save as" SLC option did not show up until I right clicked on the slc plugins in properties\plugins  individually and chose "load plugin" from that menu.

Thank you ! This post solved the problem.

May need to check this for SR1, it does not show on my Rhino 5 list. 

Thanks Pascal.



© 2020   Created by McNeel Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service