Hi,

I guess this is not a Rhino problem, but it it occurred after its installation.

I had Rhino4 and Rhino5 WIP installed and then upgraded to Rhino5. Rhino4 was still on the computer.

As part of my work routine I tried to open DWGs with Rhino5 to convert them. First I found Rhino5 under 'open with', but the drawing was actually opened with Rhino4 (always).

So then I reinstalled Rhino5 without effect. Then I deinstalled Rhino4 and now there is no Rhino to find under 'open with', even after reinstalling Rhino5 a few times.

Anyone any ideas?

Regards

Frank

Views: 285

Replies to This Discussion

Hi Frank- yeah...  there is definitely a bug with Rhino's file associations - it is on our bug list and will probably be fixed in the second service release of V5.  Can you, under OpenWith, choose the last item, "Choose default program..." and in that dialog, Browse for Rhino 5?

-Pascal

pascal@mcneel.com 

Hi Pascal,

Thanks for the quick reply.

It does not open with Rhino5, even if I browse for it and choose it as default.

I use Rhino for many years and I have pushed our company to use this software and now version 5. Especially the section tools are a geat feature.

So I am a little disappointed that this bug has creaped into the final version. Especially as we run 8 licenses over Zoo, so a mixed use of Rhino4 and 5 is not possible.

Are there any release dates for the service pack 1 and 2?

Regards

Frank

I was able to work around the problem by using "regedit" to delete the registry key:

 

HKEY_CLASSES_ROOT\Applications\Rhino.exe

 

as both Administrator and normal user.  Then, choose a file that you want opened by default with Rhino 5 and go through the usual "Open With" process, but use the "Browse" option to set the path to Rhino 5.  Note that you will have to choose exactly one of the 32-bit or 64-bit versions, since both have executables named "Rhino.exe".  Once done, Rhino 5 should show up as an icon for future "Open With" dialogs.

The problem was that the paths under this key referred to the WIP  (as normal user) and Beta (as administrator) paths, not the release version paths. Because the paths were wrong, the "Open With" dialog could not access an icon for Rhino 5, and therefore omitted it from the list.  Moreover, the "Browse" option will not update the paths under that registry key, even if different, so we are stuck deleting the key and starting over.

Hope this helps,

Demian M. Nave
Engineer
Propulsor Technology, Inc.

Works perfectly now. Many Thanks Demian

Frank

How / where do I find regedit to change it?

I have Windows 7 . With this OS when I go into the System folder to find "Rhino.exe" that file is not listed that way. There is only the Rhino icon next to "Rhino" listed as an application file. In addition because the file is only named "Rhino" instead of "Rhino 5.0" when I go through "open with " It does not recognise it as separate from any of the other Rhino versions, and then won't show up in the list on "open with".

Then I changed the name of the file with the icon "Rhino" to "Rhino 5" . Now it shows up in "open with " and I was able to change it to the default. However now it won't open because it says it can't connect to the Zoo, which I don't have and don't need as a single license user. Frustrating.

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service