Hi Dale

Is there a way to add more methods to the Intellisense / AutoCompletion of the RhinoScriptEdidor in Rhino5. 

I remember the Monkey PlugIn in R4 included the _MonkeySyntaxTreeEditor command which was quite helpful.

Even without this little I would like to add my own classes to the SyntaxTree .xml files but I can´t find where these .xml are saved in the new editor. (If at all still accessible)

Is there a way to add more stuff?  

Thanks 

Tags: Monkey, RhinoScript, SyntaxTree

Views: 142

Replies to This Discussion

Hi Steffen,

Try creating the following folder:

%CommonApplicationData%\McNeel\Rhinoceros\5.0\MonkeyEditor\Resources

and then put your syntaxml file inside it.

Does this help?

-- Dale

Hi Dale 


.. this is exactly what I was looking for,

thanks a lot

Hi Dale 

sorry to bother again. This is really a minor issue but when I type in the ScriptEditor and choose from the drop down menus, the rest of the row is wiped out. 

I know the old MonkeyEditor behaved differently but I it seems that I can´t set the new editor to do the same.

Hi Steffen,

No bother. But, I am not picturing what you are describing. How can I repeat what you are seeing? Perhaps a screen capture would help?

Thanks,

 -- Dale

lets say I have a row like this:

Call Rhino.VectorCrossProduct(Array(0, 0, 1), Array(1, 0, 0))

now, I realize I don´t want .VectorCrossProduct() , but .VectorCreate() instead (lets say I misspelled it)

I'd usually move the cursor and start typing .VectorC... and can choose from the different methods:

after that I´m left with only the method but everything to the right is gone.

I guess it's just a key combination (e.g. Tab  or Shift+Tab ? ) or  a setting in the options I can´t find.

Hi Dale 

One or two weeks ago I installed an update, and after that this issue seems to be fixed.

I guess it has something to do with it :)

 
Thanks.

However I have the feeling that another thing broke with it.


Before,  pressing [ALT]+[Left] would make the intelli-sense box appear (including my custom variables)
Now this combination appears to be set to "Nudge" in the Rhino main window again. 

.. here are the settings I use in the ScriptEditor:


  

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service