Hi, I am trying to do quick renderings in Rhino 5 but end up with a dark shadow obscuring detail.  I am using render command and can not find any way in the options to switch off the shadows.  We use the images for instruction sheets where we would like information to be as clear and simple as possible.

The same command in Rhino 4 did not produce this effect.  Any ideas?

Thanks!

Views: 3035

Attachments:

Replies to This Discussion

Hi,

Shadows in rendered views are new in V5 which is why you didn't see them in V4.  You can turn them off per mode.  One of the easiest ways to do this is to show the Display panel - type DisplayProperties in the command line or right click on another open tab and check the display item.  In the active viewport, the most common display parameters will be shown for the active mode.  If for example you have Rendered, you can simply uncheck shadows.

The classic way to do this is to go to Tools>Options>View>Display Modes>Rendered>Shadows and uncheck the "Shadows on" box.  In there you will also find all the settings to fine tune shadows if you need them.

Oh, and by the way, for doing instruction sheets, you might try taking screenshots of Technical display mode, for B/W printed stuff this works very nicely...

----H

Thank you, a lot to play with and to learn.

I like the technical and pen display options too.

Adriaan

I Adriaan- there is no way to turn off shadows for the default light in Render - you can get around this in a couple of ways-

Place a light yourself and turn off shadows for the light.

Add an environment and turn on skylighting (Lights panel... Slower)

Use ViewCaptureToFile to capture the viewport rather than make a full render- Rhino 5's Rendered display mode with shadows disabled may be just fine as a quick rendering.

-Pascal

pascal@mcneel.com

Sorry, I understood Rendered viewport, because the shadows are new there in V5...

----H

Thank you Pascal, Using Rendered display mode with all the settings off and then using ViewCaptureToFile does the trick.

Now I must just figure out how to make the X and Y axis invisible.... there is a setting for Z off or on.  (or move the model so they are out of sight!)

Adriaan

Hi Adriaan- if you toggle the grid (F7 by default) it should work, or, if you edit the settings in the main controls for this, in Options > View >Display modes (you can get there directly by clicking on the 'Edit "rendered" settings' button at the bottom of the Display panel) There, on the Grid page, you can set 'Grid usage' to 'Mode specific settings' and that will expose the setting you need. Any luck?

-Pascal

pascal@mcneel.com

Thank you Pascal, so easy when you know where to find it!

All working according to plan now.

Adriaan

Like Pascal said, one light with shadow set to 0 is a  good solution, thanks guys.

But I wanted to know how to control the Default lights.. to set set THEM to stop producing projected shadows, instead of having to create new ones...

Thanks Diego, it does work better.  But it is a lot of extra work for us - each rendering requires a new angle, and often multiple tries to get it right.  And we have 30+ images per sheet.

I was hoping that "ViewCaptureToFile" of a rendered viewport would work, but the image quality is not good enough for printing the instruction sheets.

It will be great if the shadow from the default light can be switched off...  Any chance of that in an update Pascal?

 

You can use this comand, i think someone from McNeel pointed me this:

_-ViewCaptureToFile (with underscore and hyphen)

Where you can set the resolution of your viewport. It may help you get less aliasing.

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service