Take a look at the picture below.

Views: 810

Replies to This Discussion

Hi Ryan,


The rhino 4 option has been replaced so that 3D mouse ought to be reacting according to the Tools->Rhino Options->View-> Pan: Always pan parallel views option in Rhino 5, but currently isn't. A workaround until the issue has been fixed would be to press shift and ctrl while initially rotating to break out of the plan view. Ctrl+Shift is also the proposed workflow when "Always pan parallel views" is checked.

Hope this helps

Markus

Markus,

  Do you know if this problem has been addressed yet?  I would like to upgrade to Rhino 5.0 but am not able to because of this problem.

I spoke with Brian Gillespie about this a couple weeks ago.  He said the spaceball interface is written and maintained at 3DConnexion not at Rhino, and that he didn't know whether they're aware of this bug or intend to fix it.  He also mentioned -- in as many words -- that if they do know about it, they probably don't think it's important enough to bother with.

I'm not optimistic.  I suppose I'll have to use Rhino 5 sometime since I paid for it, but ugh.

Have you tried SR1? Is this is how you expect it to work?

How do I get it?  When I do "check for updates" in Rhino 5 it says "The McNeel Update Service is unavailable".  And I'm not finding it at http://www.rhino3d.com/download

Have you disabled check for updates somehow? 

For the download, add a /5 to the end of your link.

----H

My "About Rhinoceros" says:  Version 5.0  (5.1.20927.2215, 9/27/2012)

Does that sound right?

The download at http://www.rhino3d.com/download/5 is the 9/27 release, which appears to be the same one I have.

I haven't, to my knowledge, disabled checking for updates.  The "Check for updates" dialog has a big red X and says (as noted) "The McNeel Update Service is unavailable".  In that dialog, the "Check Now" link opens a browser window which says I have the newest available.

The download at http://www.rhino3d.com/download/5 is the 9/27 release, which appears to be the same one I have.

Hmm, yeah, that appears to be SR0, I don't think the SR1 has been put up yet.  I don't know how to get the service release candidate except from  inside Rhino. The latest version is:  Version 5 (5.1.30121.1550, 21/1/13)

I don't know why check for updates is disabled on your end...  To get the SR1 candidate, you have to change the update frequency to service release candidate in Options>Updates and statistics.

----H

Ok, I set it to get release candidates and then it got it.  Thanks.

Sadly the plan-view-rotate bug is not fixed.

You can see this without a spaceball if you use the alt-arrow keys for view manipulation (Tools/Options/Modeling Aids/Nudge/Nudge keys).  If it were doing what Rhino 4 did when the "Rotate plan parallel views" option was on, alt-arrow in those views would rotate the viewport.  But instead they pan it.

*bump*  This is a severe problem for me, disappointed to find it in the production release.  Please fix.

This is a reply to Bathsheba's last comment on 25th January.

Currently the 3D Mouse will rotate parallel views if the Tools->Rhino Options->View-> Pan: Always pan parallel views option in Rhino 5 is unchecked. It will only rotate a plan view if you press shift+ctrl (same as 2d mouse and nudge keys) and once a plan view is rotated it is no longer a plan view, just a parallel view.

In Rhino 4, I think the nudge keys are unrelated to the Tools->Rhino Options->View->Spaceball->Rotate plan parallel views option: Set the nudge keys to arrow keys and alt+arrow will rotate the plan view irrespective of the Spaceball->Rotate plan parallel views option setting. In Rhino 5 the nudge keys appear to work the same as the 3D Mouse and the 2d mouse: to break out of a plan view you need to also press shift+ctrl. Again, once the parallel view is no longer a plan view alt+arrow will rotate the view.

If you do not like the shift+ctrl work flow for input devices in plan views my suggestion would be to start a new thread about it.

In your first post to this thread, back in July last year, you said:

The rhino 4 option has been replaced so that 3D mouse ought to be reacting according to the Tools->Rhino Options->View-> Pan: Always pan parallel views option in Rhino 5, but currently isn't.

I feel like this bug, which is still here, already has a thread: this one.  If you want I can start another one, but is that going to help?

I'm sorry to be contrary.  If there's been a decision to not fix this, tell me that and I'll shut up. Sadly, but I will.  But right now I feel like it's a known bug, and therefore it's reasonable to bump this thread from time to time and ask when will it be fixed?

Is doing that once every six months too often?

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service