I have upgraded from Rhino 4 to  5.0  but in so doing the file association did not change...Rhino 4 still tries to open Rhino 5 files automatically...

I have windows 7.... I would rather re install Rhino 5.0 after switching off some sort of blocking, than do what is suggested on the web..

What should I try,  to switch the file association to Rhino 5.0?

Thanks 

Basil

Views: 49

Replies to This Discussion

Hi Basil- this discussion may help... but it is a bug, as far as I know.

http://v5.rhino3d.com/forum/topics/rhino5-does-not-appear-under-ope...

-Pascal

pascal@mcneel.com

So is this the recommended solution?

I was able to work around the problem by using "regedit" to delete the registry key:

HKEY_CLASSES_ROOT\Applications\Rhino.exe

as both Administrator and normal user.  Then, choose a file that you want opened by default with Rhino 5 and go through the usual "Open With" process, but use the "Browse" option to set the path to Rhino 5.  Note that you will have to choose exactly one of the 32-bit or 64-bit versions, since both have executables named "Rhino.exe".  Once done, Rhino 5 should show up as an icon for future "Open With" dialogs.

The problem was that the paths under this key referred to the WIP  (as normal user) and Beta (as administrator) paths, not the release version paths. Because the paths were wrong, the "Open With" dialog could not access an icon for Rhino 5, and therefore omitted it from the list.  Moreover, the "Browse" option will not update the paths under that registry key, even if different, so we are stuck deleting the key and starting over.

Thanks,  ----H

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service