I just bought a 3D Connection Mouse (Space Navigator for Notebooks) and it doesn't seem to work with Rhino. I'm using Windows 7 64 bit, Rhino 4 and the latest driver for the mouse. I've used the mouse in the training under the 3D connection file so I know the mouse works, it's just trying to get it to work with Rhino that seems to be tricky. Does anyone know where I go/what I need to do to make it work? Thanks in advance!

Views: 831

Replies to This Discussion

P.S. I called the 3D connection help line and their solution was to call Rhino... :-/

does the device work in the tutorial/training included with the device?


I've been playing with Connexion devices for a while and haven't encountered any issues with Rhino? Maybe it's driver/device software related?

Hi Marise- you need to install the drivers- 

http://www.3dconnexion.com/service/drivers.html

-Pascal

pascal@mcneel.com

Hi Pascal,

I just started using Rhino 5. I have a Space navigator which I've used with Rhino 4 with no problems. However in Rhino 5 I can't seem to get the settings going right.

All is well when the zoom direction is set to the "fore-aft" option in the 3Dconnextion properties device configuration settings. When I change the zoom direction to "pull up/push" (which is much more intuitive for me) down the "spin" and "roll" get mixed up, ie. roll spins anv vice versa.

I downloaded the latest driver from 3DConnexion which did not help. Rhino4 still works properly.

Is there some setting in Rhino5 that I might be missing?

Cheers, Dennis

Hi Dennis- I don't have one of these hooked up at the moment so I cannot check, but look in Options > 3dMouse . Can't remember exactly what it is called in Options and I'm kind of making this up but I think when you've got one hooked up there is a page in options for this? Anyway, there may be a setting there to swap the two controls, or in the Mouse control panel. I'll check on Monday.

-Pascal

pascal@mcneel.com

A quick update! The 32 bit version of Rhino 5 works just fine, its just the 64bit that has the issue.

Hello Pascal,

I was a bit too hasty with the quick update I made, I actually had V4 running when I got excited about the Space navigator working properly...

the 32 bit version of V5 has the same issue as the 64 bit version.

There does not seem to be any settings for a 3D mouse in Rhino 5.

A solution to this would be very helpful.

thanks, Dennis

I restarted my computer that helped. Not sure why but it's fixed! :-) I restarted two other times before this but I guess three times is the charm?! Thanks for the advice guys!

Welcome to the waive of the future.  Some people get dizzy and give up on riding this waive.  Not everyone will embrace technology as they should.

Meanwhile I look forward to the innovations that will out mode 3dconnexion entirely.  I'm sick of their monopolization and lack of progress.  There are only two other companies that exist, who make devices similar to theirs.

At any rate ...

cheers,

erik

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service