I have bin importing a .dxf in 3D from another programm called Tribon (ship design).

I opened it in Rhino 4, it contains blocks which contains each many meshs.

When I wanted to change the colour, etc. it didnt work, so I exploded the blocks into its meshs content and it worked, the colour appeared BUT the size of the file went from 6 Mo to 186 Mo, now it is actually impossible for me to work on the file!

Is there a possibility to avoid that? or to change a mesh into NURBS?

thank you,

Tags: NURBS, file, mesh, size

Views: 318

Replies to This Discussion

Not in any practical way with a file that large and complicated. 

Here's a link to a document that uses a very simple object to show the process.

Scan, cleanup, remodel - http://www.rhino3d.com/resources?id=1055

Hi John,

Thanks, I checked your pdf yesterday night, wow, so there is no function to go from a mesh to NURBS, one has to reconstruct the whole thing,

have a nice WE,

Tom

Hi Tom- in V5, you can use BlockEdit to get at the block definition without exploding it. You'll want to assign the objects materials 'By Parent' In V4 you can also do this by exploding a single instance down to the lowest level objects, making the changes to material and so on, the re-defining the block(s) using the Block command - it is possible but rather more painful. The BlockEdit functionality is available, in a crude way, for V4 here:

http://wiki.mcneel.com/labs/blockeditor

-Pascal

pascal@mcneel.com

Hi Pascal,

I downloaded the plugin and when I wanted to paste it in the plugin file, I discovered it was already there.

But when I open rhino and go to the plugin manager, I cannot see there inplace block edit or blockedit..

I also searched into the tool bar I don’t find it.

I don’t understand that it is there in the plug in file (the 2 files are there .rhp and .tb) but it doesn’t show in rhino when I open it somehow,

Is there something I overviewed?

Thanks

Tom

Hi Tom - does InPlaceBlockEdit work if you type it in at the command line?

-Pascal

pascal@mcneel.com

Hi Pascal,

I tried, it says "command unknown"

Tom

Hi Tom- I am not sure the instructions are all that clear on that wiki page... Try this:

Unzip the rhp file to some folder where you want to keep it- the Rhino installation PLug-ins folder is OK, but anywhere is fine as long as you remember where it is. From this location, drag and drop the rhp file onto an open Rhino window. Then try the command- any luck?

-Pascal

pascal@mcneel.com

Hi,
yes, this time it worked but I only have few option there, it looks like I can only add objects into the block,
I dont see where I can change the colour of the block from inside,
greets,
Tom

Hi Tom- try this:

Make a box, Make a block of the box. Copy the block a couple of times.

Make a sphere- select  one of the blocks and the sphere and make a new block. Copy it a couple of times.

Now, select an instance of the second block, and InPlaceBlockEdit - you'll see that you can edit either the original block or the second one- select the second one.

See how now you can access the items in that block- so, select the sphere and move it. OK, and you'll see all instances of this block show the moved sphere.

InPlaceBlockEdit an instance of the second block again but choose the first block in the list- you can now access the box that you made orginally. Add a FilletEdge to this box and OK. See that all the blocks now have a filleted edge.

Etc etc. 

I think the edit you need to make is  Properties > Material > By Parent on the lowest level block objects.

 Any luck?

-Pascal

pascal@mcneel.com

Hi Pascal,

I tried the inPlaceBlock as you said and it worked, I also understand its function now.

You are right, what I need in this case is a little different, it is a question of colour, that the block in the layer does not take the proper colour of the layer nor of the material of the layer, it stays grey.

I tried to assign the material "from parents" or even the object "from parents" but it doesnt work, mmh..difficult

So I explode it one level down and sometimes it works (not always), I mean it takes the colour of the layer as the block is exploded in one or few meshes.

I also noticed that every time I explode the block it moves from the layer where I have the block, back to the "layer0", so I have to put it again in the layer where I put it in.

this are a very strange magic that is happening here, I confess, I cannot follow really why and how :)

Hi Pascal,

I had written a reply but somehow it disappeared..

I was saying that I tried the exemples for the inplaceblockedit and it worked but as you said, what I need in this case is a little differnt.

I tried with the "By parent" also doesnt work,

how I do is by exploding one time the block but it also not work always.

something strange there is that when I explode the block into its meshes, it goes to the layer 0 automatically, so I have to put it back manually into its proper layer where the colour and material is ok.

Then the outter lines of the polygons of the mesh take the colour of the layer but not the surface of the polygon, not always I mean.
Do you understand why this could happen? Do you know what I could do to have the polygons also taking the layer colour or material colour?

N.B: I dont use the command shaded view, but really the render (from Rhino)

greets

Tom

Hi Tom- this should work. When you edit a block, select the mesh that is in the block and change its layer and also change its material assignment to By Parent.

-Pascal

pascal@mcneel.com

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service