Recently I've been having a problem where in the shaded mode and rendered modes, some of my meshes will completely disappear until I save, close, and then reopen a file. They are still selectable while invisible. This is a new problem with files that I've used for over a year already. The disappearing meshes are always from 3d scan generated .stl files. I have the latest Nvidia drivers installed, running on Windows 7, Rhino 5 Commercial.

Has anyone else experienced this? Does anyone have any ideas as to why this may be happening?

Best,

Seth

Views: 228

Replies to This Discussion

Hi Seth- can you send me a small, if possible, Rhino file that shows what you are asking about? Do the meshes check out with the Check or CheckMesh(V4) command?

-Pascal

pascal@mcneel.com

Hi Pascal,

Sure, I can send you an example of the meshes. It's weird though that it recurs but only occasionally.

The meshes do check out okay. Here's an example:

This is a good mesh.

Important things to consider with this mesh:
Mesh has 1649 naked edges. Although this does not necessarily mean that the mesh is bad,
naked edges can cause problems if the ultimate goal is STL output.
Mesh has 21 faces where the face normal differs substantially from the vertex normals.
Although this does not necessarily mean that the mesh is bad,
these normals can cause problems if the ultimate goal is for rendering or boolean purposes.
Mesh has 44 pairs of faces that intersect each other. Although this does not
necessarily mean that the mesh is bad, it can cause problems if you're doing mesh boolean operations with it.

Thanks for looking, I'll email the file in a little bit.

-Seth

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service