I'm working on sf tank at the moment and when I've been making the track links I've noticed a strange behaviour. When I'm adding a small fillet (fillet edge) to the links sometimes it works and sometimes not. The funny thing that if that works on one it should work on all - as they are items that should be identical (created by rigid arraying along curve).

But that's not all - I've noticed that when I box select a couple of edges fillet fails quite often. But when I select the same edges one by one the fillet works....

Any ideas what's happening? Again filleting takes me by surprise ;) ....

Tags: edge, fillet

Views: 209

Replies to This Discussion

Oh, and I almost fogot - I'm running version 5.1.30129.1756 .

Hi Przemek - can you post or send me an example file?

thanks,

-Pascal

pascal@mcneel.com

sure :) . Give me a while - I'm working on the part atm. Luckily I do a lot of incrementa saves - as soon as I finish the part I'll get back to the problematic step :) .

OK, so I've uploaded the tracks - and here's the pic of the track with fillets, so you'll know where I applied them :) .

OK, so I've uploaded the tracks - and here's the pic of the track with fillets, so you'll know where I applied them :) .

The file can be found here:

https://dl.dropbox.com/u/42025148/trackslinks.zip

Hi Przemek - thanks... I am not quite with you, yet, but I've been a bit dense today in general, so maybe a just need an espresso - the objects in the file are already filleted, right?- I was hoping to see the ones that are not filleted so I could try to reproduce the problems you reported. Presumably, you'd fillet one of these and then array, correct? Or are there fillets still to be added here? if so where?

thanks, 

-Pascal

pascal@mcneel.com

let me check that - maybe I've uploaded wrong file :D . Yeah, it may be I need cofee more than you ;)

yup, it looks I fooled myself and sent you the file that has some of the links with fillets and some without :D . This one should work better:

https://dl.dropbox.com/u/42025148/tracks2.zip

It is an earlier version , before I repositioned and rotated some of the links.

Oh and fillets have been added after array - I know it is dumb, but after I tweaked the position of the links so they have matched the whole wheels system better and then  realized that those would look better with some fillets I decided to go the hard way ;) (and yeah, I've cleaned history the moments before the thought popped in - "hmmm.... it would be easier to identify links if I add fillets"" ....) .

Because the filletedge behaved strangley I've been switching between 0.09 and .089 radius and "distance between rails" / "rolling ball" .

Hi Przemek - so far here I do not see any failures *if* I select all the edges in a chain- , like up one side and down the other of one face in the blocks to be filleted. If I accidentally leave out an edge- easy to do, especially with window selection, and hard to see, then if will fail to build/trim the selected edge fillets correctly. I am using our latest here- that could well have bearing on things as well as there were some tune ups lately. I'll try an older build as well.... Seems OK so far...

-Pascal

pascal@mcneel.com

thx Pascal. I'll give it a 2nd look too - but after I get some sleep :D . I'm almost sure I haven't missed any edges - I had this issue on a couple of links and I think I looked at those cases closely.

As mentioned I've get around it by changing the radius slightly and/or changing fillet mode. But still I've been a tad suprised - if a given setup worked on one in theory it should work on all.

Oh, that brought me to comclusion that something strange must have indeed happened - on couple of links I simply used "set all" feature and by changing radius I get fillet to work  (so no new edges have been selected), even though the bigger one worked on previous link.

Ok, I'm getting some sleep now :D .... Will get back to the issue with a fresh mind tomorrow :) .

Got a sec to record a short video showing one of the issues - on 2 parts that should be identical (arrayed along curve) fillet edge works differently.

https://dl.dropbox.com/u/42025148/fillet_ontracks2.zip

I'll try to find the spots where selecting the edges in different order (window selecting vs picking the edges one by one) ended up with different results as well.

Hi  Przemek - for some reason Media Player does not want to play this clip. No useful reason given. 

-Pascal

pascal@mcneel.com

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service