Scaling noise texture for use in animating water surface

Hmmm, not sure if I can explain this. I have successfully animated water per Marika's post here Waves but My problem seems to be with the noise texture when I try to scale it for a scene. Waves are big offshore and small in rivers and lakes (Yea I know based on wind). I have a 20' Yacht in calm inland water so I would like some small ripple-like waves. I have tried to adjust every single parameter associated with the noise texture to accomplish this with no success. In the texture panel, under "Mapping" the are settings for Offset, Size, and Rotation, adjusting the size "seems" to be the answer...but it only seems to respond to bigger, as You try to make it smaller it gets to a point and no matter how small of a decimal number You put in it refuses to respond but oddly enough the Thumbnail for the noise texture does reflect the changes and gets smaller as You think it should. If only the texture on your surface would respond as well as the thumbnail does everything would be great....

Views: 299

Replies to This Discussion

Rhino Ver.5

Hi Carl- I've asked Marika to chime in...

-Pascal

pascal@mcneel.com

Thanks Pascal, but what I'm talking about here has nothing to do with Bongo. Its about Rhino 5's displacement texture.

ermmmph. I'll read more carefully... sorry- I'll take a look.

-Pascal

pascal@mcneel.com

Probably, the mesh resolution is the limiting factor- you may need to apply a custom, fine mesh (object Properties > Custom mesh)  to the object to get it to respond to small textures with any accuracy. Keep in mind that this is displacing the render mesh in 3d, so there needs to be sufficient resolution in the mesh. 

Does that help at all?

-Pascal

pascal@mcneel.com

I'm still experimenting, Yes I think You are on to something there. I am having a little luck with using inches as a drawing units even though the yacht is 20' long, for some reason this lets Me reduce the aggressiveness of the displacement/noise texture. Thank You for Your help! If You can think of something I may try please let Me know-I'm in no hurry and I will post/share any discovery's...

Hi Carl- try this:

-select the surface that is to be displaced. 

- in Properties, click on Cusom Mesh and Adjust

- Set Minimum initial grid to some large number, like 5000

- Uncheck 'Simple planes' if the surface is a plane.

Now, does your texture displace more like what you expect with the finer mesh?

-Pascal

pascal@mcneel.com

Something appears to be major bugged in this whole noise texture displacement system because I cant revert/reverse My setting changes and end up back where I started it just seems to get "stuck" in large texture mode while for some bewildering reason the thumbnail for the noise texture responds to all changes and acts like the way the actual applied texture on the object should behave.  Can You make this feature work as good as it does in the thumbnail preview?: ).....Please don't waste anymore of Your resources on this for Me its just not that important and I'm sure You have bigger fish to fry! I will try to make a youtube video. Im sure its My lack of understanding of the process..Thank You very much

Hi Carl- dunno if this helps, but I've attached an example of a plane with a custom mesh and one with the default mesh as the starting point for ApplyDisplacement. The texture itself is set to repeat 6 times in each direction and while you can see the repeat on the default mesh, the custom meshed object shows the displacement pattern much more clearly due the finer mesh. If you repeat the texture more, you'll see the custom meshed object start to lose resolution because the mesh is no longer fine enough to keep up, so to speak.  Note you  can also set the mesh quality used by Displacement in the object properties' Displacement page and get a similar effect. 

-Pascal

pascal@mcneel.com

Attachments:

RSS

Translate

© 2014   Created by McNeel Admin.

Badges  |  Report an Issue  |  Terms of Service